Edit on GitHub

Updating Pimcore

Upgrading within Version 6

  • Carefully read our Upgrade Notes before any update.
  • Check your version constraint for pimcore/pimcore in your composer.json and adapt it if necessary to match with the desired target version.
  • Run COMPOSER_MEMORY_LIMIT=-1 composer update

Composer update runs Pimcore migrations automatically. To run core migrations manually (e.g. when using composer install), use: bin/console pimcore:migrations:migrate -s pimcore_core -n

Upgrading to Version 6 from earlier Versions