Version:

Installation

Minimum Requirements

  • Pimcore >= 10.2
  • Pimcore Data Hub >= 1.0

Install

Install bundle via composer:

composer require pimcore/headless-documents

Enable bundle via console or extensions manager:

php bin/console pimcore:bundle:enable PimcoreHeadlessDocumentsBundle
php bin/console pimcore:bundle:install PimcoreHeadlessDocumentsBundle

Check if the bundle has been installed:

php bin/console pimcore:bundle:list
+---------------------------------+---------+-----------+----+-----+-----+
| Bundle                          | Enabled | Installed | I? | UI? | UP? |
+---------------------------------+---------+-----------+----+-----+-----+
| PimcoreHeadlessDocumentsBundle  | ✔       | ✔        | ❌  | ✔  | ❌ |
+---------------------------------+---------+-----------+----+-----+-----+

Required Backend User Permission

To create or modify Headless Document templates & bricks configuration, user needs to meet one of following criteria:

  • be an admin
  • have pimcore_headless_documents_config permission